I’m a huge fan of my T-Mobile data plan, mainly for the unlimited global data… Once I get it working, it generally keeps working, but getting the settings just right can be tricky because my phone is a Verizon phone, and I use Verizon primarily when I am at home in the US. Here’s what I have found that will get your T-Mobile International Roaming working on a [Verizon] Samsung Galaxy S5.

  1. Go to Settings -> More Networks -> Mobile networks
  2. Set Network Mode to LTE/GSM/UMTS
  3. Create a T-Mobile Access Point Name with the following specifications:
  • Name: t-mobile
  • APN: fast.t-mobile.com
  • Proxy: Not set
  • Port: Not set
  • Username: Not set
  • Password: Not set
  • Server: Not set
  • MMSC: https://mms.msg.eng.t-mobile.com/mms.wapenc
  • Multimedia message proxy: Not set
  • Multimedia message port: Not set
  • MCC: 310
  • MNC: 260
  • Authentication type: Not set
  • APN type: Not set
  • APN protocol: IPv4
  • APN roaming protocol:  IPv4
  • Mobile virtual network operator type: Not set
  • Mobile virtual network operator value: Not set

That should do the trick! If for some reason it’s still not working, here are a few other things you can try.

  1. Restart the phone.
  2. Go back into Mobile Networks and manually choose your Network Operator. I usually find that one network is significantly superior to the others.
  3. Go back into Mobile Networks and toggle between Network Mode Global and Network Mode LTE/GSM/UMTS.

There’s definitely some trial and error that goes into getting the settings to work perfectly, and sometimes I find that even when moving from one country to another I need to play around with the settings a bit, but this should get you on the right track!